Which version of Zend Server for IBM i do I have?

Here is the easiest way to determine which version of Zend Server is installed on a given IBM i system.

From a 5250 command line, follow these four steps:

1. GO LICPGM
2. Take option 10 (Display installed licensed programs)
3. Scroll down to the licensed program 2ZSVRPI 
     (on my system it's the last entry)
4. Read the product description,
     containing version numbers for Zend Server and PHP
     in the form "Zend Server for IBM i [version] ( PHP [version])"

On my IBM i, I see:
2ZSVRPI   *INSTALLED   Zend Server for IBM i 5.6.0 ( PHP 5.3 )
so Zend Server is at 5.6.0 and PHP is 5.3.

Thanks to Zend’s Sam Pinkhasov for this tip.

This entry was posted in IBM i, iSeries, PHP, System i, Web development, Zend Server, Zend's PHP toolkit for IBM i and tagged , , , . Bookmark the permalink.

2 Responses to Which version of Zend Server for IBM i do I have?

  1. Nick Litten says:

    Just what I was looking for… Thanks. Sadlty for me, the answer was “its not even installed” on this machine DUH

  2. Alan Seiden says:

    Not for long, I hope, Nick! Good luck.

Leave a Reply

Your email address will not be published. Required fields are marked *

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>